Skip to content

sharding: table 't' does not support INSERT #613

Description

@sanikolaev

Bug Description:

insert into c:t(id) values(1) fails with table 't' does not support INSERT:

MRE:

mysql> create cluster c;
Query OK, 0 rows affected (0.13 sec)

# join to the cluster on another node

mysql> create table c:t shards='3' rf='2';
Query OK, 0 rows affected (3.02 sec)

mysql> insert into c:t(id) values(1);
ERROR 1064 (42000): table 't' does not support INSERT

It works fine without replication:

mysql> create table t shards='3' rf='1';
Query OK, 0 rows affected (2.16 sec)

mysql> insert into t(id) values(1);
Query OK, 0 rows affected (0.07 sec)

Manticore Search Version:

Manticore 13.15.6 6cd1dbaa8@25102709 dev (columnar 8.1.0 e1522a2@25100213) (secondary 8.1.0 e1522a2@25100213) (knn 8.1.0 e1522a2@25100213) (embeddings 1.0.1)

Operating System Version:

Ubuntu Jammy (dev2)

Have you tried the latest development version?

No

Internal Checklist:

To be completed by the assignee. Check off tasks that have been completed or are not applicable.

Details
  • Implementation completed
  • Tests developed
  • Documentation updated
  • Documentation reviewed

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

bugSomething isn't working

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions