Skip to content

chore(deps): update dependency sphinx to v9.2.0 - #88

Open
renovate[bot] wants to merge 1 commit into
mainfrom
renovate/sphinx-9.x
Open

renovate[bot] wants to merge 1 commit into
mainfrom
renovate/sphinx-9.x

Conversation

@renovate

@renovate renovate Bot commented Oct 25, 2026

Copy link
Copy Markdown
Contributor

This PR contains the following updates:

Package Change Age Confidence
sphinx (changelog) ==9.1.1 → ==9.2.0 age confidence

Release Notes

sphinx-doc/sphinx (sphinx)

v9.2.0

Compare Source

=====================================

Dependencies


Configuration

📅 Schedule: (UTC)

  • Branch creation
    • At any time (no schedule defined)
  • Automerge
    • At any time (no schedule defined)

🚦 Automerge: Enabled.

♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this PR and you won't be reminded about this update again.


  • If you want to rebase/retry this PR, check this box

This PR was generated by Mend Renovate. View the repository job log.

@renovate
renovate Bot enabled auto-merge (rebase) October 25, 2026 00:33
@renovate

renovate Bot commented Oct 25, 2026

Copy link
Copy Markdown
Contributor Author

⚠️ Artifact update problem

Renovate failed to update an artifact related to this branch. You probably do not want to merge this PR as-is.

♻ Renovate will retry this branch, including artifacts, only when one of the following happens:

  • any of the package files in this branch needs updating, or
  • the branch becomes conflicted, or
  • you click the rebase/retry checkbox if found above, or
  • you rename this PR's title to start with "rebase!" to trigger it manually

The artifact failure details are included below:

File name: uv.lock
Using CPython 3.15.1 interpreter at: /opt/containerbase/tools/python/3.15.1/bin/python3
error: No solution found when resolving dependencies for split (markers: python_full_version == '3.12.*')
  cause: Because the requested Python version (>=3.12) does not satisfy Python>=3.13 and sphinx==9.2.0 depends on Python>=3.13, we can conclude that sphinx==9.2.0 cannot be used.
         And because only sphinx<=9.2.0 is available, we can conclude that sphinx>=9.2.0 cannot be used.
         And because arsc-writer:dev depends on sphinx==9.2.0 and your project requires arsc-writer:dev, we can conclude that your project's requirements are unsatisfiable.

hint: While the active Python version is 3.15, the resolution failed for other Python versions supported by your project. Consider limiting your project's supported Python versions using `requires-python`.

hint: The `requires-python` value (>=3.12) includes Python versions that are not supported by your dependencies (e.g., sphinx==9.2.0 only supports >=3.13). Consider using a more restrictive `requires-python` value (like >=3.13).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Projects

None yet

Development

Successfully merging this pull request may close these issues.

0 participants